Araştırma ve ödevleriniz için her türlü kaynağı ve dokümanı En Geniş Araştırma ve Ödev Sitesi: www.arsivbelge.com ile bulabilir ve İsterseniz siz de kendi belge ve çalışmalarınızı gönderebilirsiniz!
Her türlü ödev ve dokümanı
www.arsivbelge.com ile kolayca bulabilirsiniz!


Araştırmalarınız için Arama Yapın:






  
Excel Hakkında Bilgiler - 2

                    

www.arsivbelge.com
Excel Hakkında Bilgiler - 2 dokümanıyla ilgili bilgi için yazıyı inceleyebilirsiniz. Binlerce kaynak ve araştırmanın yer aldığı www.arsivbelge.com sitemizden ücretsiz yararlanabilirsiniz.
Excel Hakkında Bilgiler - 2 başlıklı doküman hakkında bilgi yazının devamında...
Ödev ve Araştırmalarınız için binlerce dokümanı www.arsivbelge.com sitesinde kolayca bulabilirsiniz.

Microsoft Excel Hakkında Bilgiler – 2

(Konunun Devamıdır. Konunun öncesi için tıklayınız.)

4.2.9. KUVVET Fonksiyonu

Üssü alınmış bir sayının sonucunu verir.

Sözdizimi

KUVVET(sayı;üs)

Sayı temel sayıdır. Gerçek sayılar olabilir.

Üs temel sayının yükseltileceği üstür.

  • Temel sayının yükseltileceği üssü göstermek için KUVVET fonksiyonu yerine “^” işleci kullanılabilir; örneğin 5^2.

Formül

Açıklama (Sonuç)

=KUVVET(5;2)

5′in karesi (25)

=KUVVET(98,6;3,2)

98,6 üssü 3,2 (2401077)

=KUVVET(4;5/4)

4 üssü 5/4 (5,656854)

4.2.10. BUGÜN Fonksiyonu

Geçerli tarihin seri sayısını verir. Seri sayısı, Microsoft Excel’in tarih ve zaman hesaplamalarında kullandığı tarih-zaman kodudur. Hücre biçimi fonksiyon girilmeden önce Genel ise, sonuç tarih olarak biçimlendirilir.

Sözdizimi

BUGÜN( )

Excel, tarihleri ardışık seri numaralar olarak saklar ve böylece tarihler hesaplamalarda kullanılabilir. Varsayılan değer olarak, 1 Ocak 1900 tarihi için 1 seri numarası kullanılır. Bu tarihten 39.448 gün sonrasına denk düşen 1 Ocak 2008′in seri numarası ise 39448 olur.

4.2.11. ŞİMDİ Fonksiyonu

Geçerli tarih ve zamanın seri numarasını verir. Hücre biçimi fonksiyon girilmeden önce Genel ise, sonuç tarih olarak biçimlendirilir.

Sözdizimi

ŞİMDİ( )

Microsoft Excel hesaplamalarda kullanılabilmeleri için tarihleri sıralı seri numaraları olarak saklamaktadır. Varsayılan olarak, 1 Ocak 1900′ün seri numarası 1′dir, bundan dolayı 1 Ocak 1900′den 39.448 gün sonra olması nedeniyle 1 Ocak 2008′in sayısı 39448′dir.

Seri sayıda ondalık noktanın sağındaki sayılar saati, soldakiler de tarihi gösterir. Örneğin, seri sayısı 0,5, saat olarak öğlen 12:00 gösterir.

Yalnızca çalışma sayfası hesaplandığında veya fonksiyonu içeren makro çalıştırıldığında, ŞİMDİ fonksiyonu değişir. Bu sürekli olarak güncellenmez.

4.2.12. HAFTANINGÜNÜ Fonksiyonu

Bir tarihe karşılık gelen haftanın gününü verir. Varsayılan değer olarak, gün, 1′den (Pazar) 7′ye (Cumartesi) kadar bir tamsayı olarak verilir.

Sözdizimi

HAFTANINGÜNÜ(seri_no, döndür_tür)

Seri_no bulmaya çalıştığınız günün tarihini gösteren ardışık sayıdır. Tarihler, TARİH fonksiyonu kullanılarak girilmiş veya başka formüller veya fonksiyonlarla elde edilmiş olmalıdır. Örneğin, Mayıs 2008′in 23. günü için TARİH(2008,5,23) formülünü kullanın. Tarihler metin biçiminde girilmişse sorunlar çıkabilir.

Döndür_tür sonuç değerinin türünü belirleyen bir türdür.

Döndür_tür

Verilen Sayı

1 veya belirtilmemiş

1′den (Pazar) 7′ye (Cumartesi) kadar sayılar. Microsoft Excel’in önceki sürümlerinde olduğu gibi.

2

1′den (Pazartesi) 7′ye (Pazar) kadar sayılar.

3

0′den (Pazartesi) 6′ye (Pazar) kadar sayılar.

Örnek

 

A

B

Formül

Açıklama (Sonuç)

1

Veri

 

=HAFTANINGÜNÜ(A2)

1′den (Pazar) 7′ye (Cumartesi) kadar sayılarla gösterilen haftanın günü (5)

2

14.02.2008

 

3

 

 

=HAFTANINGÜNÜ(A2,2)

1′den (Pazartesi) 7′ye (Pazar) kadar sayılarla gösterilen haftanın günü (4)

4

 

 

5

 

 

=HAFTANINGÜNÜ(A2,3)

0′dan (Pazartesi) 6′ya (Pazar) kadar sayılarla gösterilen haftanın günü (3)

6

 

 

4.2.13. BÜYÜKHARF Fonksiyonu

Metni büyük harfe çevirir.

Sözdizimi

BÜYÜKHARF(metin)

Metin büyük harfe çevrilmesini istediğiniz metindir. Metin bir başvuru veya metin dizesi olabilir.

Örnek

 

A

C

Formül

Açıklama (Sonuç)

1

Veri

 

=BÜYÜKHARF(A2)

İlk dizenin büyük harfe dönüştürülmüş biçimi (TOPLAM)

2

Toplam

 

=BÜYÜKHARF(A3)

İkinci dizenin büyük harfe dönüştürülmüş biçimi (VERİM)

3

verim

 

 

 

4.2.14. KÜÇÜKHARF Fonksiyonu

Metni küçük harfe çevirir.

Sözdizimi

KÜÇÜKHARF(metin)

Metin küçük harfe çevrilmesini istediğiniz metindir. Metin bir başvuru veya metin dizesi olabilir.

Örnek

 

A

B

Formül

Açıklama (Sonuç)

1

Veri

 

=KÜÇÜKHARF(A2)

İlk dizenin küçük harfe çevrilmiş biçimi (e. e. birliği)

2

E. E. Birliği

 

=KÜÇÜKHARF(A3)

Son dizenin küçük harfe çevrilmiş biçimi (apt. 2b)

3

Apt. 2B

 

 

 

4.2.15. SOLDAN Fonksiyonu

SOLDAN, bir metin dizesindeki belirttiğiniz karakter sayısına bağlı olarak ilk karakter veya karakterleri verir.

SOLDAN(metin;sayı_karakterler)

Metin ayıklamak istediğiniz karakterleri içeren metin dizisidir.

Sayı_karakterler SOLDAN fonksiyonunun ayıklamasını istediğiniz karakter sayısını belirler.

  • Sayı_karakterler sıfırdan büyük veya sıfıra eşit olmalıdır.
  • Sayı_karakterler metin uzunluğundan büyükse, SOLDAN fonksiyonu tüm metni verir.
  • Sayı_karakterler belirtilmezse, 1 olduğu varsayılır.

 

A

B

Formül

Açıklama (Sonuç)

1

Veri

 

=SOLDAN(A2;5)

Birinci dizedeki ilk beş karakter (Satış)

2

Satış Fiyatı

 

=SOLDAN(A3)

İkinci dizedeki ilk karakter (İ)

3

İsveç

 

 

 

4.2.16. SAĞDAN Fonksiyonu

SAĞDAN, bir metin dizesindeki belirttiğiniz karakter sayısına bağlı olarak son karakter veya karakterleri verir.

SAĞDAN(metin;sayı_karakterler)

Metin ayıklamak istediğiniz karakterleri içeren metin dizisidir.

Sayı_karakterler SAĞDAN fonksiyonunun ayıklamasını istediğiniz karakter sayısını belirler.

  • Sayı_karakterler sıfırdan büyük veya sıfıra eşit olmalıdır.
  • Sayı_karakterler metin uzunluğundan büyükse, SAĞDAN fonksiyonu tüm metni verir.
  • Sayı_karakterler belirtilmezse, 1 olduğu varsayılır.

 

A

B

Formül

Açıklama (Sonuç)

1

Veri

 

=SAĞDAN(A2;6)

İlk dizenin son altı karakterini verir (Fiyatı)

2

Satış Fiyatı

 

=SAĞDAN(A3)

İkinci dizedeki son karakter (ı)

3

Stok Numarası

 

 

 

4.2.17. UZUNLUK Fonksiyonu

UZUNLUK metin dizesindeki karakter sayısını verir.

Sözdizimi

UZUNLUK(metin)

Metin uzunluğunu bulmak istediğiniz metindir. Boşluklar da karakter olarak sayılır.

Örnek

 

A

B

Formül

Açıklama (Sonuç)

1

Veri

 

=UZUNLUK(A2)

A2’de bulunan yazıdaki karakter sayısı (3)

2

MYO

 

=UZUNLUK(A3)

A2’de bulunan yazıdaki karakter sayısı (21)

3

Nevşehir Üniversitesi

 

 

 

4.2.18. BİRLEŞTİR Fonksiyonu

İki veya daha çok metin dizesini bir metin dizesi şeklinde birleştirir.

Sözdizimi

BİRLEŞTİR (metin1;metin2;…)

Metin1; metin2; … tek bir öğe olarak birleştirilecek 2 ile 255 arasında metin öğesidir. Metin öğeleri; metin dizeleri, sayılar veya tek hücre başvuruları olabilir.

  • Metin öğelerini birleştirmek için BİRLEŞTİR fonksiyonu yerine VE işareti (&) hesaplama işlecini de kullanabilirsiniz. Örneğin, =A1&B1, BİRLEŞTİR(A1;B1) ile aynı sonuç değerini verir.

Örnek

 

A

B

Formül

=BİRLEŞTİR(A2;” “;A3;” için nehir yoğunluğu “;A4;”/m”)

1

Veri

 

2

Tatlı su alabalığı

 

Açıklama (Sonuç)

Yukarıdaki verilerden gelen bir cümleyi birleştirir (Tatlı su alabalığı türleri için nehir yoğunluğu 32/m)

3

türleri

 

4

32

 

 

 

4.2.19. PARÇAAL Fonksiyonu

PARÇAAL belirlediğiniz konumdan başlayarak, belirlediğiniz sayıda karakter esasında bir metin dizesinden belirli sayıda karakter verir.

Sözdizimi

PARÇAAL (metin;başlangıç_sayısı;sayı_karakterler)

Metin ayıklamak istediğiniz karakterleri içeren metindir.

Başlangıç_sayısı metinde ayıklamak istediğiniz ilk karakterin konumudur. Metin’deki ilk karakterin başlangıç_sayısı 1′dir ve böylece devam eder.

Sayı_karakterler PARÇAAL ‘ın metinden vermesini istediğiniz karakter sayısını belirler.

  • Başlangıç_sayısı, metin uzunluğundan büyükse PARÇAAL fonksiyonu “” (boş metin) verir.
  • Başlangıç_sayısı, metin büyüklüğünden küçük, ancak başlangıç_sayısı ve sayı_karakterler birlikte metin uzunluğunu aşarsa, PARÇAAL metnin sonuna kadar olan karakterleri verir.
  • Başlangıç_sayısı 1′den küçükse, PARÇAAL fonksiyonu #DEĞER! hata değeri verir.
  • Sayı_karakterler negatifse, PARÇAAL fonksiyonu #DEĞER! hata değeri verir.

Örnek

 

A

C

Formül

Açıklama (Sonuç)

1

Veri

 

=PARÇAAL(A2;1;5)

Birinci karakterle başlayan ilk beş karakter (Sulak)

2

Sulak Arazi

 

= PARÇAAL (A2;7;20)

Yedinci karakterden başlayan yirmi karakter (Arazi)

3

 

 

= PARÇAAL (A2;20;5)

Başlangıç noktasının dizenin uzunluğundan daha büyük olması nedeniyle boş metin verilir ()

4

 

 

4.2.20. KIRP Fonksiyonu

Sözcükler arasındaki tek boşluklar dışında metinden tüm boşlukları kaldırır. Boşlukları düzenli olmayan, başka bir uygulamadan aldığınız metin üzerinde KIRP işlevini kullanın.

Sözdizimi

KIRP(metin)

Metin içinden boşlukların kaldırılmasını istediğiniz metindir.

Örnek

Formül

Açıklama (Sonuç)

=KIRP(” İlk Çeyrek Gelirleri  “)

Formüldeki metnin (İlk Çeyrek Gelirleri) başındaki ve sonundaki boşlukları kaldırır.

4.2.21. BUL Fonksiyonu

BUL, bir metin dizesini başka bir metin dizesi içinde bulur ve ikinci metin dizesinin ilk karakterine göre ilk metin dizesinin başlangıç konumunun sayısını döndürür.

Sözdizimi

BUL(bul_metin;metin;başlangıç_sayısı)

Bul_metin bulmak istediğiniz metindir.

Metin bulmak istediğiniz metni içeren metindir.

Başlangıç_sayısı aramanın başlatılacağı karakteri belirtir. Metin’deki ilk karakter sayısı 1′dir. Başlangıç_sayısı belirtilmezse 1 olduğu varsayılır.

  • BUL büyük/küçük harf duyarlıdır ve joker karakter kullanımına izin vermez.
  • Bul_metin “” (boş metin) ise, BUL arama dizesindeki ilk karakteri (başlangıç_sayısı veya 1 numaralı karakter) seçer.
  • Bul_metinde joker karakter olamaz.
  • Bul_metin, metinde yoksa BUL fonksiyonu #DEĞER! hata değeri verir.
  • Başlangıç_sayısı sıfırdan büyük değilse, BUL fonksiyonu #DEĞER! hata değeri verir.
  • Başlangıç_sayısı, metinin uzunluğundan büyükse, BUL fonksiyonu #DEĞER! hata değeri verir.
  • Belirli sayıda karakteri atlamak için başlangıç_sayısı’nı kullanın. Örneğin BUL fonksiyonunu kullandığınızı ve “AGF0093.GençErkekKıyafeti” metin dizesiyle çalıştığınızı varsayalım. Metin dizesinin açıklayıcı bölümündeki ilk “G” karakterinin sayısını bulmak için, metnin seri numarası kısmının aranmaması amacıyla başlangıç_sayısı’nı 8 olarak belirtin. BUL fonksiyonu 8. karakterden başlar, bir sonraki karakterde bul_metin’i bulur ve 9 sayısını verir. BUL, başlangıç_sayısı 1′den büyükse atladığınız karakterleri de sayarak, karakter sayısını her zaman metin’in başlangıcını esas alarak verir.

Örnek

 

A

C

Formül

Açıklama (Sonuç)

1

Veri

 

=BUL(“M”;A2)

Birinci “M” konumu (1)

2

Meryem Meriç

 

=BUL(“m”;A2)

Birinci “m” konumu (6)

3

 

 

=BUL(“M”;A2;3)

Üçüncü karakterle başlayan dizede, birinci “M” konumu (8)

4

 

 

4.2.22. ETOPLA Fonksiyonu

Verilen ölçütle belirlenen hücreleri toplar.

Sözdizimi

ETOPLA(aralık;ölçüt;toplam_aralığı)

Aralık ölçütlerle değerlendirilmesini istediğiniz hücre aralığıdır. Her aralıktaki hücreler, sayı veya sayı içeren ad, dizi veya başvuru olmalıdır. Boşluk ve metin göz ardı edilir.

Ölçüt hangi hücrelerin toplanacağını belirleyen bir sayı, ifade veya metin biçimindeki ölçüttür. Örneğin, Ölçüt 32, “32″, “>32″ veya “elmalar” olarak ifade edilebilir.

Toplam_aralığı aralıkta karşılık gelen hücreler ölçüte uyuyorsa eklenecek gerçek hücrelerdir. Toplam_aralığı atlanırsa, aralıktaki hücreler hem ölçütler tarafından değerlendirilir, hem de ölçütleri karşılıyorsa eklenir.

  • Toplam_aralığının aralıkla aynı boyutta ve şekilde olması gerekmez. Eklenen gerçek hücreler başlangıç hücresi olarak toplam_aralığında üst, sol hücreler kullanılarak saptanıp aralıkla boyut ve şekil olarak uygun olan hücreleri de ekler. Örneğin:

Aralık aşağıdaki gibi

Ve toplam_aralığı aşağıdaki gibiyse

Gerçek hücreler aşağıdaki gibi olur

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Ölçütlerde joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Soru işareti tek karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterin önüne bir tilde işareti (~) koyun

Örnek

 

A

B

C

Formül

Açıklama (Sonuç)

1

Mülk Değeri

Komisyon

 

=ETOPLA(A2:A5;”>160000″;B2:B5)

160.000′in üzerindeki mülk değerleri için komisyonların toplamı (63.000)

2

100.000

7.000

 

3

200.000

14.000

 

4

300.000

21.000

 

=ETOPLA(A2:A5;”>160000″)

160.000′in üzerindeki mülk değerleri toplamı (900.000)

5

400.000

28.000

 

 

 

 

 

 

 

 

 

=ETOPLA(A2:A5,”=300000″,B2:B3)

300.000′ e eşit mülk değerleri için komisyonların toplamı (21.000)

 

 

 

 

 

 

 

 

4.2.23. EĞERSAY Fonksiyonu

EĞERSAY işlevi, bir aralıkta yer alan ve belirttiğiniz tek bir ölçüte uyan hücrelerin sayısını sayar. Örneğin, belirli bir harfle başlayan tüm hücreleri veya belirttiğiniz bir sayıdan daha küçük ya da daha büyük sayılar içeren tüm hücreleri sayabilirsiniz. Örneğin, A sütununda görev listesinin ve B sütununda da her göreve atanmış kişinin adının bulunduğu bir çalışma sayfanız olduğunu varsayalım. EĞERSAY işlevini kullanarak bir kişinin adının B sütununda kaç kez geçtiğini sayabilir, bu yolla söz konusu kişiye kaç görev atandığını saptayabilirsiniz. Örneğin:

=EĞERSAY(B2:B25,”Neşe”)

Sözdizimi

EĞERSAY(aralık, ölçüt)

EĞERSAY işlevinin sözdizimi aşağıdaki bağımsız değişkenleri (bağımsız değişken: Bir eylem, olay, yöntem, özellik, fonksiyon veya yordama bilgi sağlayan bir değer.) içerir:

Aralık:  Gerekli. Numaralar veya adlar, diziler ya da sayı içeren başvurular da içinde olmak üzere sayılacak bir veya birden çok hücre. Boşluk ve metin değerleri göz ardı edilir.

Ölçütler:  Gerekli. Hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu ya da metin dizesi. Örneğin, ölçüt 32, “>32″, B4, “elmalar” veya “32″ olarak gösterilebilir.

Not

Ölçütte, soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. Soru işareti tek karakter bulurken, yıldız işareti bir dizi karakter bulur. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Ölçütler büyük/küçük harfe duyarlı değildir; örneğin, “elmalar” dizesiyle “ELMALAR” dizesi aynı hücreleri eşleştirir.

Örnek

 

A

B

C

1

Veri

Veri

 

2

elma

32

 

3

portakal

54

 

4

Şeftali

75

 

5

Elma

86

 

6

 

 

 

7

Formül

Açıklama

Sonuç

8

=EĞERSAY(A2:A5;”elma”)

A2 ile A5 arasında yer alan elma sözcüğünü içeren hücrelerin sayısı

2

9

=EĞERSAY(A2:A5;A4)

A2 ile A5 arasında yer alan şeftali sözcüğünü içeren hücrelerin sayısı

1

10

=EĞERSAY(A2:A5;A3) + EĞERSAY(A2:A5;A2)

A2 ile A5 arasında yer alan portakal ve elma sözcüklerini içeren hücrelerin sayısı

3

11

=EĞERSAY(B2:B5;”>55”)

B2 ile B5 arasında yer alan ve 55’ten büyük bir değer içeren hücrelerin sayısı

2

12

=EĞERSAY(B2:B5;”<>”&B4)

B2 ile B5 arasında yer alan ve değerleri 75’e eşit olmayan hücrelerin sayısı

3

13

 

 

 

4.2.24. VE Fonksiyonu

Tüm bağımsız değişkenleri DOĞRU’ysa DOĞRU’yu verir; Bir ya da daha fazla bağımsız değişkeni YANLIŞ’sa YANLIŞ’ı verir.

Sözdizimi

VE(mantıksal1;mantıksal2; …)

Mantıksal1;mantıksal2;… DOĞRU ya da YANLIŞ olabilen, test etmek istediğiniz 1 ile 255 arası koşuldur.

  • Bağımsız değişkenler, DOĞRU veya YANLIŞ gibi mantıksal değerler oluşturmalı veya mantıksal değerler içeren diziler veya başvurular olmalıdır.
  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.
  • Belirlenen aralık hiçbir mantıksal değer içermiyorsa VE işlevi #DEĞER! hata değerini verir.

Örnek

Formül

Açıklama (Sonuç)

=VE(DOĞRU; DOĞRU)

Tüm bağımsız değişkenler DOĞRU (DOĞRU)

=VE(DOĞRU; YANLIŞ)

Bir bağımsız değişken YANLIŞ (YANLIŞ)

=VE(2+2=4; 2+3=5)

Tüm bağımsız değişkenler DOĞRU olarak değerlendirildi (DOĞRU)

 

 

A

C

Formül

Açıklama (Sonuç)

1

Veri

 

=VE(1<A2; A2<100)

50, 1 ile 100 arasında olduğu için (DOĞRU)

2

50

 

=VE(1<A3; A3<100)

A3, 1’den büyük olmasına rağmen 100’den küçük olduğu için yanlış

3

104

 

 

 

4.2.25. YADA Fonksiyonu

Bağımsız değişkenlerden biri DOĞRU’ysa DOĞRU’yu verir; tüm bağımsız değişkenler YANLIŞ’sa da YANLIŞ’ı verir.

Sözdizimi

YADA(mantıksal1;mantıksal2;…)

Mantıksal1, mantıksal2, … DOĞRU veya YANLIŞ olduğunu sınamak istediğiniz 1 ile 255 arasındaki koşullardır.

  • Bağımsız değişkenlerin DOĞRU veya YANLIŞ gibi mantıksal değerleri veya mantıksal değerler içeren dizileri veya başvuruları değerlendirmeleri gerekir.
  • Bir dizi veya başvuru bağımsız değişkeni metin veya boş hücreler içeriyorsa, bu değerler dikkate alınmaz.
  • Belirtilen aralık mantıksal değer içermiyorsa, YADA fonksiyonu #DEĞER! hata değeri verir.
  • Bir dizide bir değerin olup olmadığını görmek için bir YADA dizi formülü kullanabilirsiniz.

Örnek

Formül

Açıklama (Sonuç)

=YADA(DOĞRU)

Bir bağımsız değişken DOĞRU’dur (DOĞRU)

=YADA(1+1=1;2+2=5)

Tüm bağımsız değişkenler YANLIŞ olarak değerlendirilir (YANLIŞ)

=YADA(DOĞRU;YANLIŞ;DOĞRU)

En azından bir bağımsız değişken DOĞRU’dur (DOĞRU)

4.2.26. DEĞİL Fonksiyonu

Bağımsız değişkeninin değerini tersine çevirir. Bir değerin belirli bir değere eşit olup olmadığını denetlemek istediğinizde DEĞİL fonksiyonunu kullanın.

Sözdizimi

DEĞİL(mantıksal)

Mantıksal DOĞRU veya YANLIŞ olarak değerlendirilebilecek değerdir.

  • Mantıksal YANLIŞ ise, DEĞİL DOĞRU’yu; mantıksal DOĞRU ise, DEĞİL YANLIŞ’ı verir.

Örnek

Formül

Sonuç (Açıklama)

=DEĞİL(YANLIŞ)

YANLIŞ’ın tersini verir (DOĞRU)

=DEĞİL(1+1=2)

DOĞRU olarak değerlendirilen bir denklemin tersini verir (YANLIŞ)

4.2.27. EĞER Fonksiyonu

Belirttiğiniz koşul DOĞRU olarak değerlendirilirse bir değer, YANLIŞ olarak değerlendirilirse başka bir değer verir. Değerler ve formüller üzerinde koşullu sınamalar yürütmek için EĞER fonksiyonunu kullanın.

Sözdizimi

EĞER(mantıksal_sınama;eğer_doğruysa_değer;eğer_yanlışsa_değer)

Mantıksal_sınama DOĞRU veya YANLIŞ olarak değerlendirilebilecek herhangi bir değer veya deyim. Örneğin, A10=100, mantıksal bir deyimdir; A10 hücresindeki değer 100′e eşitse, deyim DOĞRU olarak değerlendirilir. Tersi durumda, YANLIŞ olarak değerlendirilir. Bu bağımsız değişken herhangi bir karşılaştırma hesabı işleci kullanabilir.

Eğer_doğruysa_değer mantıksal_sınama DOĞRU ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken “Bütçe içinde” ise ve mantıksal_sınama bağımsız değişkeni DOĞRU olarak değerlendirilirse, EĞER fonksiyonu “Bütçe içinde” metnini görüntüler. Mantıksal_sınama DOĞRU ise ve eğer_doğruysa_değer boşsa, bu bağımsız değişken 0 (sıfır) değeri verir. DOĞRU sözcüğünü görüntülemek üzere bu bağımsız değişken için DOĞRU mantıksal değerini kullanın. Eğer_doğruysa_değer başka bir formül olabilir.

Eğer_yanlışsa_değer Mantıksal_sınama YANLIŞ ise verilen değerdir. Örneğin, metin dizesindeki bu bağımsız değişken “Bütçeyi aşıyor” ise ve mantıksal_sınama bağımsız değişkeni YANLIŞ olarak değerlendirilirse, EĞER fonksiyonu “Bütçeyi aşıyor” metnini görüntüler. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer belirtilmemişse (bu, eğer_doğruysa_değer’inden sonra virgül olmamasıdır) YANLIŞ mantıksal değeri verilir. Mantıksal_sınama YANLIŞ ise ve eğer_yanlışsa_değer boşsa (bu, eğer_doğruysa_değer’inden sonra bir virgül ve onu izleyen kapatma parantezi olması durumudur) 0 (sıfır) değeri verilir. Eğer_yanlışsa_değer başka bir formül olabilir.

  • Daha ayrıntılı sınama yapmak için en çok 64 EĞER fonksiyonu eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenleri şeklinde iç içe kullanılabilir.
  • Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenleri değerlendirildiğinde, EĞER fonksiyonu bu deyimler tarafından verilen değeri verir.

Örnek

 

A

C

Formül

Açıklama (Sonuç)

1

Veri

 

=EĞER(A2<=100;”Bütçe içinde”;”Bütçeyi aşıyor”)

A2’deki sayı 100′e eşit veya küçükse, bu durumda formül “Bütçe içinde”yi görüntüler. Aksi halde, fonksiyon “Bütçeyi aşıyor” metni görüntüler (Bütçe içinde)

2

50

 

3

 

 

4

 

 

=EĞER(A2=100;TOPLA(B5:B15);”")

Yukarıdaki sayı 100 ise, B5:B15 aralığı hesaplanır. Aksi halde, boş metin (“”) verilir ()

5

 

 

Örnek

 

A

B

C

Formül

Açıklama (Sonuç)

1

Fiili Harcamalar

Öngörülen Harcamalar

 

=EĞER(A2>B2;”Bütçeyi Aşıyor”;”Tamam”)

Birinci sıranın bütçeyi aşıp aşmadığını denetler (Bütçeyi Aşıyor)

2

1500

900

 

=EĞER(A3>B3;”Bütçeyi Aşıyor”;”Tamam”)

İkinci sıranın bütçeyi aşıp aşmadığını denetler (Tamam)

3

500

900

 

4

500

925

 

 

 

5

 

 

 

 

 

Örnek

 

A

B

Formül

Açıklama (Sonuç)

1

Puan

 

=EĞER(A2>89;”A”;EĞER(A2>79;”B”;”C”))

Birinci puana harf derecesi atar (C)

2

45

 

=EĞER(A3>89;”A”;EĞER(A3>79;”B”;”C”))

İkinci puana harf derecesi atar (A)

3

90

 

=EĞER(A4>89;”A”;EĞER(A4>79;”B”;”C”))

Üçüncü puana harf derecesi atar (B)

4

82

 

 

 

4.2.28. GÜN360 Fonksiyonu

GÜN360 işlevi 360 günlük yıl temelinde (ayda 30 gün) iki tarih arasındaki gün sayısını döndürür.

Sözdizimi

GÜN360(başlangıç_tarihi, bitiş_tarihi, [yöntem])

başlangıç_tarihi, bitiş_tarihi: Gerekli. Aralarındaki gün sayısını öğrenmek istediğiniz iki tarih. Başlangıç_tarihi, bitiş_tarihi bağımsız değişkeninde belirtilen tarihten sonra geliyorsa, GÜN360 işlevi negatif bir sayı döndürür. Tarihler, TARİH işlevi kullanılarak girilmeli veya diğer formüllerin ya da işlevlerin sonuçlarından türetilmelidir. Örneğin, 23 Mayıs 2008 için TARİH(2008;5;23) kullanılmalıdır. Tarihler metin olarak girilirse sorun çıkabilir.

yöntem: İsteğe bağlı. Hesaplamada Avrupa ya da ABD yönteminin kullanılacağını belirleyen mantıksal değer.

Örnek

 

A

B

C

1

Tarihler

 

 

2

1/1/2008

 

 

3

30.1.2008

 

 

4

1.2.2008

 

 

5

31/12/2008

 

 

6

 

 

 

7

Formül

Açıklama

Sonuç

8

=GÜN360(A3;A4)

360 günlük yıl temelinde, 30/1/2001 ile 1/2/2008 tarihleri arasındaki gün sayısı

1

9

=GÜN360(A2;A5)

360günlük yıl temelinde, 1/1/2008 ile 31/12/2008 tarihleri arasındaki gün sayısı

360

10

=GÜN360(A2;A4)

360 günlük yıl temelinde, 1/1/2008 ile 1/2/2008 tarihleri arasındaki gün sayısı

30

4.2.29. YAZIM.DÜZENİ Fonksiyonu

Metin dizesindeki ilk karakteri ve metinde harf dışı karakterlerin ardından gelen diğer harfleri büyük harfe çevirir. Tüm diğer harfleri küçük harfe çevirir.

Sözdizimi

YAZIM.DÜZENİ(Metin)

Metin:   tırnak işaretleri içindeki metin, metin veren bir formül veya yer yer büyük harfle yazılmasını istediğiniz metni içeren hücre başvurusudur.

Örnek

<td va

 

A

B

Formül

Açıklama (Sonuç)


Ekleyen:Ümit SERT
Kaynak:(Alıntıdır)
Aradığınız Dokümanı Bulamadıysanız, Farklı Araştırmalar Yapmak İstiyorsanız Site İçi Arama Yapabilirsiniz!

Ödev ve Araştırmalarınız için www.arsivbelge.com Sitesinde Kaynak Arayın:


Ödev ve Araştırmalarınız için Arama Yapın:
     Benzer Dokümanları İnceleyin
Gelir - Gider Hesaplama Programı ( Excel )(12433)

Excel Hakkında Bilgiler(4223)

Makro Programlama Ders Notları(3107)

Yaşamınızı Kolaylaştıracak Pratik Bilgiler(2081)

Yemek Yaparken Yararlanacağınız Pratik Bilgiler(1960)

          Tanıtım Yazıları
      
Türkçe İtalyanca ve Almanca Cümle Çevirisi İçin Birimçevir Sitesi

Esenyurt, Beylikdüzü ve Kartal Bölgelerinde Satılık Daire İlanları

Belge Çevirisi

Siz de Tanıtım Yazısı Yayınlamak İçin Tıklayın

Diğer Dökümanlarımızı görmek için: www.arsivbelge.com tıklayın.          

Siz de Yorum Yapmak İstiyorsanız Sayfanın Altındaki Formu Kullanarak Yorum Yazabilirsiniz!

Yorum Yaz          
Öncelikle Yandaki İşlemin Sonucunu Yazın: İşlemin Sonucunu Kutucuğa Yazınız!
Ad Soyad:
          
Yorumunuz site yönetimi tarafından onaylandıktan sonra yayınlanacaktır!